08 11 / 2012

Versino numbers should be boring

If you really want to have a dotted-integer module version, then I strongly recommend that you limit your module to Perl 5.10 (or require version.pm and at least Perl 5.8.1) and that you never use an alpha version number. Always quote your dotted integer version when you define it and always use a leading-v to guide your users towards proper usage.

This is an old post, but tl;dr: if you want to use vx.y.z style versioning in your perl code, just use the quoted string version of it: use version; our $VERSION = 'v0.8.0' and don’t use v-strings or qv().

Should work with perl back to 5.8.

Permalink 1 note